Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Gumball machine - Suggestions to improve this shot

Hybrid View

  1. #1

    Gumball machine - Suggestions to improve this shot

    My first attempt at a DMM simulation in Maya 2013, inspired by the Gumball gorge scene in Wreck-it-Ralph. I would sincerely appreciate any tips to improve this shot to make it demoreel worthy. I added a Youngs damp of 1500 to the gumballs and this improved their movement; but I still have a few inter-penetrations, floaters and a couple of odd gumball pops to fix.



    Simulation time : A little less than an hour for 200 frames
    Substeps : 16 (Could this be higher?)

    Materials used:
    Gumballs - ub_rubber (Added Youngs damp of 1500, zero toughness and no plastic deformation)
    Glass shell - Weak_crystal
    Lid - ub_diamond (lowered density to 1000)

    Cheers!

  2. #2
    Great result!

    Suggestions for improvement:
    1) Turn off Glue All in the scene settings. This can improve simulation speed. DMM is not like a rigid body system where contact forces are countered at startup.
    2) Try turning objects passive at later points in the scene to avoid nonessential movement. Sometimes the subtlety of DMM is not necessary in the final frames. Try that and see how it works.
    3) Substeps can be increased to whatever you wish. Some people have jacked that up to 100!

    -Vik

  3. #3
    looks really good!
    Your scene scale seems off, the simulation is slow. What units are you working in? cm grid units in maya should have a DMMScene scale of .01.
    Once your sim is done and your happy with it I would also make the camera angle more appealing, get it close or choose an angle where things are happening in a compelling artistic way, right now it feels like a witness cam test (which it is of course)
    good luck

  4. #4
    Greetings .Friends and Vik.

    Well I have an interesting thought on this thread and this particular effect also.
    Pls spare a moment before going into this thread I request....


    Well I was also trying some similar dynamics and I change the DMM unit to .01 in order it should adhere to the default maya units,which simply means Maya treat its default units which is in CM as Meter,because in DMM the space scale is by-default set to 1.

    All right I just took a simple default dmm sphere and a cube of passive dmm object and allows the free simulation of sphere with space-scale to .01 and sub-step to 64,with Glue all set to off as Mr. Vik Told.
    My material settings are young's stiffness is set to complete 10000000 ok , density was around 10,000 and toughness to 25, friction was moved to 2 instead of .6 default. The shocking thing was all the dmm chunks are penetrating the passive object whose Density area I dipped to .01 that takes it to some where 2587 tet count.

    The things are getting better only if you change the unit set-up to .1 and play with bigger value of sub-step,but my question is if i have to play in real world then How come I going to protect my simulation?????

    Looking for a perfect and complete answer and Guys If i did anything wrong pls address to me this question is really a worth to my up coming research on DMM and many more.

    I also request to all the users pls give a try to ur self and see what you get,by the way I forgot to tell you my dmm sphere was approx 3 cm in radius.

    Hope Mr Vik come with a solution or any other way out to solve my query .Thank-you Sir in advance.
    Last edited by mayaguru; 01-18-2014 at 10:45 AM.

  5. #5
    Hi Vik and Mandark, many thanks for the suggestions. I tried these out and here are the results:

    1. I initially set the substeps to 128, which was too slow, so I've now set it to 64.

    2. Turning off Glue all improved the speed.

    3. Setting scene scale to 0.01 gave me an 'Alteast one tet too small' error message, I tried a few iterations at slightly higher values and the balls didn't collide with the glass shell until '0.5'. This seems to be similar to what mayaguru mentioned, I have a passive region at the base of the shell. I'm not sure if this is a matter of having more sub-steps or how the passive region is positioned, I'm trying out a few more options to get a good match between sim playback speed and quality

    4. As for the camera angle.. yes, it certainly needs to be more dynamic.

  6. #6
    Hi Friends Hopping to get a feedback and answer to this query.

    I am posting the video I got from the Test and Hopefully It might be useful to Sleepingbeagle also.


    http://www.youtube.com/watch?v=wcrGWvQyuzI&feature=youtu.be

  7. #7
    Hi mayaguru, I made a few adjustments to my sim and I'm getting good results now. Some issues I had before, interpenetrations, vibrating/flickering pieces are gone, or atleast they're not as visibly apparent as before. Hopefully, I'm fixing my issues the right way. Here's what I did:

    1. I got decent collisions when I rebuilt the objects to real scale (or maybe even slightly bigger). A scene scale of 0.01 was still way too fast, so I went with 0.1. Go with what works I guess.

    2. Increasing substeps helps, and I also played around with minIter(=8) and maxIter(=90) values and the ground material is set to concrete_strong even though it's passive

    3. I wonder if having a non-zero value for split limit matters even though toughness is 0

    4. In this case, I found that Glue All 'ON' got rid of a few floating glass shards

    Some screengrabs:

    https://dl.dropboxusercontent.com/u/...ls_redux02.png
    (in my first attempt, quite a few gumballs near the base wouldn't collide with the glass shell)

    https://dl.dropboxusercontent.com/u/...alls_redux.png
    (Viewport in-screen ambient occlusion awesomeness)

  8. #8
    Thanks for the info exchange Sleepingbeagle.I am also glad you took interest in solving this thread.

    But I still insist that we must also know the way out of fixing in space scale .01.I had done those things also and in .1 it seems good but to tell you more friend, I still noticed very steep shrinking and sinking of dmm shards and i switched to .25 space-scale.

    What I am interested to get is this is an error of DMM that it doesn't works in space scale .01 or may be we are missing any other important workflow to that might could help us in expanding knowledge.

    So i request you to pls search for way out for space-scale .01.

    really Appreciate yours effort and hardwork.

    Looking forward to talk to you more.

  9. #9
    Team Pixelux I am still not able to find out the solution of running a simulation with .01 space-scale.

    Pls provide me with relevant answer and solution.

    Looking to hear from you.If this is a bug or error or any limitation then also let me know I try to wait for next release o any further update or patch?

  10. #10
    Is there some reason you are changing the space scale? It's generally best to leave that alone.

    -Vik

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •