Results 1 to 4 of 4

Thread: "Refresh Surface Mesh" doesn't work on DMM objects created using "Create DMM from...

  1. #1

    Question "Refresh Surface Mesh" doesn't work on DMM objects created using "Create DMM from...

    Hey,

    So I'm not sure the best way to submit a bug, but I have noticed that the "Refresh Surface Mesh" doesn't work on DMM objects created using "Create DMM from Polymesh with AutoCage". DMM reports this error: "# Error: RuntimeError: setAttr: Not enough data was provided. The last 0 items will be skipped". It works fine on objects created using "Create DMM from Polymesh". This issue, I'm imagining, will cause workflow problems as shaders will probably need to be changed after a poly object has been made into a DMM one. The way I have been show to propagate inside and outside shader changes is by using "Refresh Surface Mesh" -- hence the issue. I'm still in the development stage of the project, but will soon be entering production -- I'm hoping there will be a resolution before then.

    I'm currently using the DMM version that comes with Maya 2012.

    Let me know if there is a work around, or a new version that fixes this issue.


    Thanks,
    Mark

  2. #2
    It has been my experience that I try to remove DMM from the process once simulation is complete. Issues transferring scenes to lighting artists, with shot building tools and different naming conventions, cachein g issues. here I explain the process i use to convert a DMM simulation into a Geometry cached poly object. The workflow is not perfect and its a pain to go back and make sim changes then propagate it through the pipe again but it works most times for me.

    http://www.pixelux.com/forums/showth...ighlight=cache

    good luck to you. My post is what im specifically talking about]

  3. #3

  4. #4
    Sorry to resurrect this thread. Has anyone solved this.
    I'm doing a pretty big simulation with lots of objects. This is what happens for me while UVing the objects.

    1. Transfer UV attributes to input surface mesh
    2. Mesh rebuilds but is invisible, lost its shader group?.
    3. Reapply the first shader, then the face shader.
    4. Rebuild mesh.....then # Error: RuntimeError: setAttr: Not enough data was provided. The last 0 items will be skipped

    I really need these internal faces. I guess I could explode the components, but I loose the glue and passive regions assigned. Bit stuck now.....

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •