PDA

View Full Version : DMM Plugin for Linux ?



_John_
09-09-2008, 03:23 AM
That would be nice to have too .

dmmjedi
10-05-2008, 08:12 PM
We have built the DMM libraries for Linux, but have not done a version of the plugin for Maya under Linux yet. We will announce it as we have further progress.

Breaker
01-14-2009, 01:51 PM
Hi dmmjedi,

Any updates on the Linux plug-in? We're keen to use this more widely although are holding off until there's Linux support.

_John_
06-09-2009, 01:18 AM
so ? is it done yet ? :D .

kidding , but it would be nice to have an update .

Dusmus
06-21-2011, 04:30 AM
Hello any infos on a linux version of DMM ? It would be great. Even something that we could beta test.

Thanks

vik
06-21-2011, 09:23 PM
We do indeed have a Linux version. However it is only available for Maya 2012 (it is actually included with Maya 2012).

Dusmus
06-22-2011, 01:58 AM
Hey Vik,

Thanks for the reply, actually that's what I thought. I'll try to get the IT guys to look into this (maya 2012 is installed but no sign of DMM I believe they didn't checked the install option)
Is PhysX available on linux as well ? I think it is but not GPU accelerated right ?


Cheers

vik
06-22-2011, 07:36 AM
I do not believe PhysX is included on anything other than Windows, but you can check with Autodesk on that. Our system is included on all platforms, and in fact, our Linux version has some enhancements to the solver to improve accuracy. DMM is fully multithreaded on all versions as well. You should also note that MPC uses our Linux version for their Kali destruction toolkit that has been getting a lot of press lately.

If you have any issues with firewalls and licenses, please drop us an email at info@pixelux.com for help.

Cheers,
Vik

Dusmus
06-23-2011, 12:43 AM
Hey Vik,

We managed to install the plug but we get the following error message while loading the DmmPlugin.py :

// Error: line 1: ImportError: file /u/soft/autodesk/maya2012-x64/bin/plug-ins/DmmPlugin.py line 7: No module named dmm.UI //

// Warning: line 1: Failed to run file: /u/soft/autodesk/maya2012-x64/bin/plug-ins/DmmPlugin.py //

// Error: line 1: (DmmPlugin) //


Any ideas ?


Much thanks,


Steve

Dusmus
06-23-2011, 01:55 AM
Ok nevermind, I didnt have the rights to access the dmm folder in the plugins directory, that's whay it couldn't load the modules. Works well now, just have to stay under 2500 tets :cry:

Cheers,

Steve

vik
06-23-2011, 05:56 AM
Glad to hear it. So this is with the plug-in installed as a part of Maya 2012 then? I assume that Maya was installed as administrator and then you ran it as a normal user?

-Vik

Dusmus
06-23-2011, 06:43 AM
Yeah this is with a maya 2012 install on Suse. The system dept installed it but forgot to give us the rights so the folder could not be read.

The 2500 tet limitation is reached pretty fast ! :D